Viewing 1 post (of 1 total)
  • Author
    Posts
  • #30711

    Support
    Keymaster

    Sometimes Windows File Sharing seems to get itself in a mess and stops allowing full access to one or more of your database files.

    This is (apparently) a recognised problem with Windows File sharing. Symptoms of the File Sharing going AWOL include (but are not limited to) :-

      – ClinicOffice reports “Windows has denied access” to database files on your network computers (but not on the one hosting the files)
      – Your network appears to be working, but ClinicOffice says it “cannot find a valid clinic database”
      – Windows reports that the “network resource is not accessible” when you know full well that it is!

    Unfortunately, simply rebooting the computer or removing and then re-instating the file sharing is often not usually sufficient to resolve this. 🙄

    This FAQ describes how to reset the File Sharing on your database folder.

    ABBREVIATED Instructions

    – Close down ClinicOffice on all computers
    – Go to your SERVER computer (the one that hosts the ClinicOffice database)
    – Remove the file sharing on the database folder
    – Create a copy of the database folder (e.g. “Copy of MyDatabase”)
    – Rename the original folder to something else (e.g. “MyDatabase.old”)
    – Rename the new “Copy of” folder to the original name
    – Re-instate the file sharing on the new folder (“MyDatabase.old” can be deleted later once it’s all working)
    – The network computers should now be able to logon correctly

    DETAILED Instructions

    Firstly, please make sure that ClinicOffice is closed down on all your computers and then do the following from your SERVER computer (i.e. the one that hosts your ClincOffice database).

    [1] Disable the Sharing on the Database Folder

      1. Locate your database folder (start by double-clicking My Computer)
      2. Right click on it, then click Sharing and Security
      3. Make a careful note of the “share name” on this screen
      4. Untick the box which says Share this folder on the network
      5. Click OK (you should see the ‘hand’ icon on your database folder has now dissappeared, indicating that the folder is no longer shared)

    [2] Create a Copy of the Folder

      1. Make a note of the folder name as we’re about to change it
      2. Click once on the folder to select it, then press F2
      3. Type in a new name for the folder (e.g. if it was “ClinicDB” you could rename it to “ClinicDB.old”) and press Enter
      4. Right click the folder and click Copy
      5. Click the Edit menu (at the top) and click Paste (you should now see something like “Copy of ClinicDB.old” appear as a new folder – you may need to scroll down to see it)
      6. Click once on this new folder to select it, then press F2
      7. Rename the new folder to whatever the original folder was called before you renamed it

    [3] Re-instate File Sharing on the New Folder

      1. Right click on the new folder which you have just renamed
      2. Click Sharing and Security
      3. Tick the box which says Share this folder on the network
      4. Enter the share name that you noted down from earlier
      5. Tick the box which says Allow network users to change my files
      6. Click OK

    You should see a ‘hand’ icon appear on your database folder which indicates that it is now being shared and this should now have resolved the issue.

    SUMMARY

    To recap what we’ve done :-

      – Disabled sharing on the original folder
      – Renamed the original folder
      – Created a copy of the original folder
      – Renamed the new copy to the whatever the original one was called
      – Re-instated the sharing on the new folder

    If you find that problems persist after having taken the above steps, then it may be that there’s a problem with your database (try running a database integrity check) but it’s more likely that there is some other networking problem.

    Here are a couple of 3rd party articles which may prove helpful in troubleshooting network faults :-

    Microsoft Knowledgebase article
    http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

    About.com article
    http://compnetworking.about.com/od/windowsnetworking/tp/winfilesharing.htm

    💡 One final thought : ClinicOffice 2005 Client/Server edition doesn’t use Windows File Sharing at all, so it may be worthwhile considering Client/Server if you’re afflicted with file sharing woes.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.