Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #30755

    When you enter a patients postcode in the individual Patient Record details it looks OK i.e. letters are capitals e.g. TS21 1HY but when you look at the details in list form under Patients, it appears as Ts21 1hy. This is the format it appears in when I export it to mail merge to produce address labels for correspondence.

    #31758

    Support
    Keymaster

    Hi Peter,

    Not sure how lowercase postcodes would have got in there – the user interface only allows you to enter uppercase ones! It could possibly have been from a patient data import.

    Anyway, here’s how to fix it…

      – Start CO2005 and logon
      – Click Tools | Advanced DB Operation
      – Copy and paste the following bit of code into the “Advanced Database Operation” window…

      UPDATE Per SET Postcode=UPPER(Postcode)

      – Now click the Execute button

    This will update all your postcodes to upper case in your database. You may need to log off and then log back on again to make sure any cached records are updated.

    #31759

    This does occur when entering new records. They appear in lower case if you don’t have the caps lock on but hold the shift key down on while entering. If you either put caps lock on or let the database automatically capitilise the postcode it appears in upper case (ie don’t hold the shift key down). It doesn’t appear as lower case when you are in the patient record, only when you export the list or when you are in the patient grid.

    Regards
    Claire

    #31760

    Hello,

    I’ve had this problem too. If you enter a postcode then move to the next cell to enter data, it automatically changes what you type to lower case.

    The only way I’ve found to get it to stay as I enter it is to save the file before moving away from the cell.

    The same is true with other fields eg surnames like McFergus, which unless you save whilst still in the field, will change to Mcfergus when saved.

    Is there a setting we should be changing or is this the way the programme is written?

    Many thanks,

    James

    #31761

    Support
    Keymaster

    We’ve identified the problem now and it has been fixed for the next update. In the meantime, please use the database code (posted above) to fix the problem.

    #31762

    Great. Thanks!

    James

    #31763

    Now that ❗ was very Cool!!!

    8)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.