Viewing 1 post (of 1 total)
  • Author
    Posts
  • #31630

    Since Vista, Windows has a built-in “auto tune” mechanism, which (in theory) should make RDP connection more stable. The problem is that some routers don’t work well with this and can actually cause RDP connections to drop intermittently.

    In these cases, disabling the “auto tune” mechanism can actually improve the situation. Here’s how :-

    [1] Run a COMMAND PROMPT as an Administrator
    (In Windows 10, you can right-click the START MENU and click “Command Prompt (Admin)”

    [2] Copy and paste the following lines one at a time (pressing ENTER after each one) :-

    NETSH INTERFACE TCP SET HEURISTICS DISABLED
    NETSH INTERFACE TCP SET GLOBAL AUTOTUNINGLEVEL=DISABLED

    [3] You can now run this command to verify that these values are now “DISABLED

    NETSH INTERFACE TCP SHOW GLOBAL

    [4] Lastly, reboot the computer for these changes to take effect.


    *** IMPORTANT NOTE ***

    If the actual cause of the disconnections is bad internet connectivity, the above steps won’t make much difference, however in some cases, we have found that the above has resolved RDP connection issues for a number of customers.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.